Desperate - Need Help

Need help? Post your questions here.

Desperate - Need Help

Unread postby mlutzow » 21 Mar 2014, 03:43

I've been running Madsonic for about a year without any problems.

I'm running M$ Windows 7 Ultimate 64bit and Madsonic updated to the latest release.

About two weeks ago My Android app started crashing and checking the Madsonic Server using "Show Madsonic in Browser" from the tray icon, the Web Browser opens and gives me a 503 error, service not available.

I've checked some logs and the log states that the Madsonic Service is flagged as an interactive service but my system is configured to disallow interactive services. I've checked the Madsonic Service and it is set to interact with the Desktop,

I have made absolutely zero changes with the exception of applying Windows updaes when released.

I think this is probably a Winblows issue, but I can't find how to resolve this. I and my users are really going through listening withdrawls.

The only other thing I've done has been to install some Linux Distros on a completely different machine, so that shouldn't be impacting this issue.

Any suggestion or an answer on how to resolve this issue is greatly appreaciated.

**Edit** After some reading I'm being pointed in the direction of something wrong with Java, then to the Madsonic app itself, very confusing as I changed nothing myself.

Thank you in Advance,

Mark
mlutzow
 
Posts: 40
Joined: 05 Feb 2013, 22:41
Has thanked: 24 times
Been thanked: 12 times

Re: Desperate - Need Help

Unread postby mlutzow » 21 Mar 2014, 21:15

Seems like no has an answer for the Windows issue.

Maybe someone can help me with this. I'm going to install Ubuntu to a partition, then I'll install Madsonic under Unbuntu, I already know I can mount with Read and Write the NTFS drives where all my A / V files are stored.

I just needs some pointers, actually an explanation how to install Madsonic under Ubuntu. I assume I need to get something like Tomcat up and running first then install Madsonic. I'm new to Linux, I feel pretty comfortable with it, but still new and need some help getting Madsonic installed and running.
mlutzow
 
Posts: 40
Joined: 05 Feb 2013, 22:41
Has thanked: 24 times
Been thanked: 12 times

Re: Desperate - Need Help

Unread postby GJ51 » 22 Mar 2014, 02:03

503 errors are usually the result of an improper shutdown/reboot of your host machine that corrupts the database.

You can search the Subsonic forums for "503 error" to read about the repair suggestions.

http://forum.subsonic.org/forum/index.php
GJ51
Contributor
Contributor
 
Posts: 194
Joined: 15 Dec 2012, 17:52
Has thanked: 68 times
Been thanked: 106 times

Re: Desperate - Need Help

Unread postby mlutzow » 22 Mar 2014, 05:40

GJ thanks for the response, I'll look into it. I spent the evening gettinh Madsonic up and running on a Linux Mint system I have, now I just need to remener how to get the NTFS networked share to automount at boot. I'm fairly certain I have the rights on the windows box serup right.

Sent from my Galaxy Note II using Tapatalk 2
mlutzow
 
Posts: 40
Joined: 05 Feb 2013, 22:41
Has thanked: 24 times
Been thanked: 12 times

Re: Desperate - Need Help

Unread postby mlutzow » 23 Mar 2014, 06:36

GJ51 wrote:503 errors are usually the result of an improper shutdown/reboot of your host machine that corrupts the database.

You can search the Subsonic forums for "503 error" to read about the repair suggestions.

http://forum.subsonic.org/forum/index.php


Thank you so very much for the response. Sure enough my whole db directory had been corrupted, all the files were zero bytes and just didn't work. Renamed the directory and Mad started up and started rebuilding, lost everything though. Thankfully a few upgrades ago I had made a backup of all the files so I copied those over and was able to restore all my users and other 'critical' settings. I'm back up and running again.

Thank you again.

Now to continuing my education with Linux and the NTFS Netwok shares...can get them to mount by browsing to them with a file browser but when adding the shares to fstab, it just won;t work.
mlutzow
 
Posts: 40
Joined: 05 Feb 2013, 22:41
Has thanked: 24 times
Been thanked: 12 times

Re: Desperate - Need Help

Unread postby GJ51 » 23 Mar 2014, 07:08

Wish I could help you there, but I've been a Microsoft guy since MS-DOS 1.0 - I've looked at Linux a few times, but my network is so Windows server dominant that I just haven't gotten motivated to learn Linux well enough to give you any advice. My son has mastered Linux and Windows as if he was born with the know-how, but then he's a lot younger than I am - LOL.

It's not a bad idea to back up the data directory once a week or so to have as a restore point in case of a crash. I see this sort of thing reported a lot, but my servers are very stable and I haven't seen a 503 error in several years even though I run multiple instances of Subsonic and Madsonic in virtual machines.

My best assessment after several forum chats is that this is most often caused by premature/improper shutdowns of the host machine. When this happens the file system doesn't allow the db time to close it's files properly which leaves the db in an unrecoverable state. Try to avoid the 4 sec. hard shutdown. If you have to do that for some reason, try to stop the madsonic and related services first if you can. Be patient whenever you do updates and allow all processes to finish before rebooting if required.

HTH
GJ51
Contributor
Contributor
 
Posts: 194
Joined: 15 Dec 2012, 17:52
Has thanked: 68 times
Been thanked: 106 times


Return to Support 5.x

Who is online

Users browsing this forum: No registered users and 1 guest