Definitive Guide to Adding Media Folders on Synology NAS?

Need help? Post your questions here.

Definitive Guide to Adding Media Folders on Synology NAS?

Unread postby Dubhead » 09 Jan 2015, 08:36

Hello,
I have had Madsonic sitting idle for months now as I have not been able to get my media folders to add properly. I have followed a number of guides and only ever had a configuration of SubSonic that ever worked which was running the SubSonic server on my Windows 8.1 machine and pointing the server to the media folders on my older Netgear ReadyNAS NV+. I have since moved on to a much nicer NAS, the Synology DS1813+ because I was excited by the ability of this machine to run SubSonic. I was able to get that configured and once (only once) did I have it successfully running properly pointing at the media folders that resided on the NAS. This made sense to me as the Server and the media were both located on the NAS. I tried to update the version of SubSonic on the Synology at some point and after that, I was never able to mount the media folders again. I then switched over to MadSonic, hoping that perhaps there might be a difference with how it sees the media folders but it appeared to have the same issues. I am now giving up on running MadSonic from the NAS and running it again back on my Windows 8.1 desktop and trying to once again get the NAS media folders added successfully to MadSonic. It is another exercise in futility with all of the different methods I have tried. Here is what I know about the setup right now:
System Info:
- Madsonic v. 5.1.5200.20141017.1252
- Windows 8.1 Pro (x64)
- Synology DS1813+ running DSM 5.1-5021 Update 2 with 4GB memory
Config Info:
- Media folder location on NAS: \volume1\Music\MP3 - No media folders found at this path
- Madsonic Service modified to login as admin user for Windows
- Permissions on media folder location set to Full for user "Everyone" and "Madsonic"
- Have also mapped NAS Media folder location to Windows as X:\Music - No media folders found at this path
- Madsonic user is same name and password as Windows and DSM user

So to the point of what I hope someone can enlighten me on, is there a more definitive guide to setting this up? I don't know why this is so difficult really (well I have read some explanations of this) but honestly my older NAS had no issues but the Synology seems very particular. I have also not seen anything quite definitive about the formatting of the path information for the media folders either that answer some basic questions like the following:

\\192.168.1.201\Music\MP3\ or \\192.168.1.201\Music\MP3 - does Madsonic see these any differently? (ie. lacking a "\" at the end?
\\NASALIASNAME\Music\MP3\ -- Will the server or NAS alias name resolve properly to the IP address if used in the path?
X:\MP3 - Why would a mapped drive not work in Madsonic where X is the NAS server?
Do relative paths work and how?

I would appreciate any insights or comments that might help on this. I have not heard much feedback on a few other posts in forums around this topic and hope that maybe that will be different this time.

Thanks,
~Dubhead 8-)
Dubhead
 
Posts: 2
Joined: 29 Oct 2014, 07:02
Has thanked: 0 time
Been thanked: 0 time

Re: Definitive Guide to Adding Media Folders on Synology NAS

Unread postby jaszladie » 14 May 2015, 19:41

Hi,

I had to play around for a while before I figured out I had to remove the dashes from my folder names. So eventually, I added: /volume1/music/AC
This worked for me. Your issue could be totally unrelated but I thought I'd share. Good luck!
jaszladie
 
Posts: 15
Joined: 31 Oct 2013, 17:16
Has thanked: 22 times
Been thanked: 2 times

Re: Definitive Guide to Adding Media Folders on Synology NAS

Unread postby Dubhead » 04 Jun 2015, 18:50

Just a quick update to this thread I started months ago. I have done absolutely nothing as far as changes go in how my media folders are mapped and now all my music appears. I had really given up on this and now I am not sure why this suddenly works?? In any event, I do home it is stable and lasts. I am wondering if the publishing of the network share for my Synology DS1813+ changed somehow. There were some firmware updates between the last time I looked at this, so I would suspect that may have had something to do with this. Here is what is working for me now:

\\NAS_ALIAS_NAME\Music\MP3

"NAS_ALIAS_NAME" would be substituted with whatever name you might use for your Synology DiskStation. I have a one word alias so I am not using any separators as jaszladie had indicated there was trouble for them with having "-" in the name.

Maybe Synology did fix this issue with the firmware updates. I had read in a few places that these NAS units did have some notorious trouble with Subsonic/Madsonic and media folder mapping. Time will tell.

~Dubhead 8-)
Dubhead
 
Posts: 2
Joined: 29 Oct 2014, 07:02
Has thanked: 0 time
Been thanked: 0 time


Return to Support 5.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron