Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 crashing

Need help? Post your questions here.

Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 crashing

Unread postby diablo2424 » 24 Mar 2015, 01:49

Hello, I have recently setup Madsonic v5.1.5140 along with Java 1.7.0_75-b13 running on my Raspberry Pi2 Model B (quad-core, 1GB of RAM, running newest Raspbian Debian-based Linux for ARMv7). After about a day or so of running, I notice that the Madsonic service has failed with an error within /var/madsonic/madsonic_sh.log pointing me to a Java failure with details in /usr/share/madsonic/hs_err_pid9742.log, which is attached.



After a reboot, everything runs fine for another day or so, then the same error comes back. This is where my expertise ends, and I am at a loss as to what to try to fix this. Does anyone have any ideas on what I can do to try to keep this from happening constantly? Or has anyone else experience this?
Attachments
hs_err_pid9742.log
Java Error
(61.11 KiB) Downloaded 54 times
diablo2424
 
Posts: 3
Joined: 25 Jan 2014, 15:23
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby Larzon » 08 Apr 2015, 17:09

Hello,

I have Madsonic 5.2 running on a Raspberry Pi 2 without any issues. However I'm not using OpenJDK 1.7

Maybe you could try updating to Oracle Java 1.8 JRE

Here's my server information:
jetty/8.y.z-SNAPSHOT, java 1.8.0_33, Linux 3.18.9-v7+ (arm) (122.8 MB / 248.0 MB)
Larzon
 
Posts: 5
Joined: 08 Jun 2014, 20:55
Has thanked: 0 time
Been thanked: 3 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby Madevil » 29 Apr 2015, 02:04

I would recommend you to use the Oracle JAVA8 implementation,
it's more reliably than OpenJDK and has ARM HW Floating point support.

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-arm-downloads-2187472.html

Click the download button of Java Platform (JDK) 8. Click to Accept License Agreement,
download jdk-8u33-linux-arm-vfp-hflt.tar.gz for Linux ARM v6/v7 Hard Float ABI.

Log-in Raspberry Pi, enter the command to extract jdk-8u33-linux-arm-vfp-hflt.tar.gz to /opt directory.

Code: Select all
sudo tar zxvf jdk-8u33-linux-arm-vfp-hflt.tar.gz -C /opt


Set default java and javac to the new installed jdk8.

Code: Select all
sudo update-alternatives --install /usr/bin/javac javac /opt/jdk1.8.0_33/bin/javac 1
sudo update-alternatives --install /usr/bin/java java /opt/jdk1.8.0_33/bin/java 1

sudo update-alternatives --config javac
sudo update-alternatives --config java

After all, verify with the commands with -verion option.

Code: Select all
$ java -version
User avatar
Madevil
Administrator
Administrator
 
Posts: 880
Joined: 07 Dec 2012, 03:58
Has thanked: 1280 times
Been thanked: 947 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby sterlingdax » 03 Jun 2015, 01:07

I was having the same problem, using the same java version, will give this a shot and report back, was very, very frustrating, crossing my fingers!
sterlingdax
 
Posts: 4
Joined: 31 May 2015, 21:25
Has thanked: 0 time
Been thanked: 0 time

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby sterlingdax » 03 Jun 2015, 02:07

For the record, the PI now ships with Oracle Java, after swapping back to it, I remember doing it the first time.

I'm too new to post links, but look on the Raspberry Pi site
sterlingdax
 
Posts: 4
Joined: 31 May 2015, 21:25
Has thanked: 0 time
Been thanked: 0 time

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby diablo2424 » 04 Jun 2015, 03:21

Thank you for the guide Madevil, however, I tried this, and the server worked for a day or two, then back to the same 503 Service unavailable error. :thumbsdown:
diablo2424
 
Posts: 3
Joined: 25 Jan 2014, 15:23
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby addseo1115 » 09 Jun 2015, 10:19

Thanks for sharing. :)
addseo1115
 
Posts: 23
Joined: 15 May 2015, 04:43
Has thanked: 0 time
Been thanked: 2 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby diablo2424 » 09 Jun 2015, 19:43

You're welcome... since I have been unsuccessful at getting Madsonic to stay running for more than 24-48 hours, I have switched back to the newest version of Subsonic (5.2.1 (build 4428) – March 4, 2015) running Java 1.8.0_33 with the instructions included above from MadEvil, and it's been running great.

Hopefully once the next version of Madsonic comes out, I can switch back as I'm beginning to miss some of the features of Madsonic, that Subsonic doesn't have.
diablo2424
 
Posts: 3
Joined: 25 Jan 2014, 15:23
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic 5.1.5140 & Java 1.7.0_75-b13 Raspberry Pi2 cras

Unread postby addseo1115 » 15 Jun 2015, 09:41

that is good infomations and useful, thank for sharing. :thumbsup: :thumbsup: :thumbsup:
addseo1115
 
Posts: 23
Joined: 15 May 2015, 04:43
Has thanked: 0 time
Been thanked: 2 times


Return to Support 5.x

Who is online

Users browsing this forum: No registered users and 1 guest