Video Transcode on ARM7

Need help? Post your questions here.

Video Transcode on ARM7

Unread postby blindpet » 31 Oct 2015, 01:07

I'm using an arm7 device (the Raspberry Pi and Orange Pi) and am trying to use the transcoder function for video. Plex transcodes on these devices with some tweaks so I'm hoping Madsonic can too.

I tried installing the debian .deb package and then installing ffmpeg from the repo. I am using oracle java 8 and Raspbian jessie. The about section says the transcoder is found but when I try and play a video in the browser it just shows a black box. Mad sonic log files don't show anything.

The video I am testing is big buck bunny 320x180.mp4

Can you point me in the right direction? I have tried 5.1.5250 and 5.1.5260, the transcoder is found for 5250 and not found for 5260.
blindpet
 
Posts: 1
Joined: 31 Oct 2015, 01:02
Has thanked: 0 time
Been thanked: 0 time

Re: Video Transcode on ARM7

Unread postby struds » 31 Oct 2015, 21:06

What repo did you find ffmpeg on? Everything I've seen online says that you have to compile it from source for the pi.

Edit - been having trouble with ffmpeg, I've installed libav-tools instead from apt-get, it's based on ffmpeg but actually has raspberry pi builds. Then symlink avconv to the transcoers folder. In subsonic just replace ffmpeg with avconv under transcoers (where it's based on ffmpeg it seems to use the same arguments)
struds
 
Posts: 1
Joined: 31 Oct 2015, 21:03
Has thanked: 0 time
Been thanked: 0 time


Return to Support 5.x

Who is online

Users browsing this forum: No registered users and 3 guests