Page 1 of 1

Problems with FLAC Files

Unread postPosted: 20 Nov 2015, 08:12
by pizzaazzip
This is one item on a somewhat long list of issues I'm trying to get around currently, I'll try my best to spare the theatrics. I installed MADSONIC 5.1.5250.20150814.0325 to my raspberry pi Raspbian install a few days ago and I cannot get FLAC or M4A files to work using the webapp (most of my music is in FLAC). If I play mp3 files they work with only a few seconds to buffer.

Using the official subsonic android app, I am able to play FLAC and MP3 files but unfortunately no M4A files (I don't think this is an iTunes DRM issue because these songs were bought after apple did away with that protection). Clementine seems to work fine for playing FLAC files, although I think I'm currently experiencing a bug because I cannot seem to see any mp3 or m4a files, likely because they are in a separate folder.

I changed the transcoding settings and worked for me to get FLAC files to work using apps. I tried linking it but the forum thinks I'm too spammy. Granted I never tested playback before changing my transcoding settings, directly after I did this FLAC files would still not play in the web app but did show a buffer bar.

What broke FLAC buffering in the webapp and playback in apps was a link from 2009 involving sudo apt-get install flac and copying it over to the transcode folder for madsonic. I tried it both with default transcoding settings and the ones I changed. After deleting files I put in /var/madsonic/transcode/ everything was working again.

I have not been able to test this outside of my home network, I can't seem to figure out how to register the whole [customurl] thing. I'm also guessing I haven't done port forwarding correctly.

Anyone have any ideas?

Re: Problems with FLAC Files

Unread postPosted: 30 Nov 2015, 06:33
by pizzaazzip
Nevermind. I setup a plex server and that does what I want out of the box.

Problems with FLAC Files

Unread postPosted: 08 Aug 2017, 08:34
by richardmlldk
nevermind. the above code works fine. i never deleted the cached images. deleted the cache, re-uploaded all the files and it is now adding the watermarks