DLNA server cannot play file on my Denon AVR

Post your Server Bug Report

DLNA server cannot play file on my Denon AVR

Unread postby xamandre » 27 Sep 2014, 14:45

I have a Denon x1000 AVR, i can browse into my madsonic server without problems but i cannot play any file. I tried with mp3 and flac, same problem.
My denon just tell me "impossibile to play file".
This is the error i get in madsonic logs :
Code: Select all
[2014-09-27 15:25:41,887] ERROR FolderBasedContentDirectory - UPnP error: java.lang.IllegalArgumentException: fromIndex(2) > toIndex(1)
java.lang.IllegalArgumentException: fromIndex(2) > toIndex(1)
   at java.util.ArrayList.subListRangeCheck(Unknown Source)
   at java.util.ArrayList.subList(Unknown Source)
   at org.madsonic.service.upnp.FolderBasedContentDirectory.subList(FolderBasedContentDirectory.java:197)
   at org.madsonic.service.upnp.FolderBasedContentDirectory.browseRoot(FolderBasedContentDirectory.java:166)
   at org.madsonic.service.upnp.FolderBasedContentDirectory.browse(FolderBasedContentDirectory.java:84)
   at org.fourthline.cling.support.contentdirectory.AbstractContentDirectoryService.browse(AbstractContentDirectoryService.java:200)
   at sun.reflect.GeneratedMethodAccessor105.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
   at java.lang.reflect.Method.invoke(Unknown Source)
   at org.seamless.util.Reflections.invoke(Reflections.java:41)
   at org.fourthline.cling.model.action.MethodActionExecutor.execute(MethodActionExecutor.java:90)
   at org.fourthline.cling.model.action.AbstractActionExecutor$1.execute(AbstractActionExecutor.java:73)
   at org.fourthline.cling.model.DefaultServiceManager.execute(DefaultServiceManager.java:128)
   at org.fourthline.cling.model.action.AbstractActionExecutor.execute(AbstractActionExecutor.java:71)
   at org.fourthline.cling.protocol.sync.ReceivingAction.executeSync(ReceivingAction.java:104)
   at org.fourthline.cling.protocol.ReceivingSync.execute(ReceivingSync.java:63)
   at org.fourthline.cling.protocol.ReceivingAsync.run(ReceivingAsync.java:71)
   at org.fourthline.cling.transport.spi.UpnpStream.process(UpnpStream.java:82)
   at org.fourthline.cling.transport.impl.apache.HttpServerConnectionUpnpStream$UpnpHttpService.doService(HttpServerConnectionUpnpStream.java:210)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:290)
   at org.fourthline.cling.transport.impl.apache.HttpServerConnectionUpnpStream.run(HttpServerConnectionUpnpStream.java:114)
   at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)



What can i do to fix it ?

Thanks !

A.
xamandre
 
Posts: 1
Joined: 27 Sep 2014, 11:59
Has thanked: 0 time
Been thanked: 0 time

Return to Bug Reports 5.x

Who is online

Users browsing this forum: No registered users and 3 guests