https does not work

Post your Server Bug Report

https does not work

Unread postby illumilore » 17 Dec 2015, 22:31

After following the instructions to enable https by changing the config file line for the args to MADSONIC_ARGS="--port 4040 --https-port=4443 --init-memory=300 --max-memory=1050", when accessing the https port, the web browser is never able to connect.
illumilore
 
Posts: 7
Joined: 17 Aug 2015, 23:59
Has thanked: 0 time
Been thanked: 3 times

Re: https does not work

Unread postby gurutech » 17 Dec 2015, 22:57

If you are running this on Linux, you will need to open the 4443 port on the OS firewall.
gurutech
Contributor
Contributor
 
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 12 times
Been thanked: 130 times

Re: https does not work

Unread postby jake- » 18 Dec 2015, 10:32

illumilore wrote:After following the instructions to enable https by changing the config file line for the args to MADSONIC_ARGS="--port 4040 --https-port=4443 --init-memory=300 --max-memory=1050", when accessing the https port, the web browser is never able to connect.


Maybe a typo because https port is 443 not 4443?

https://your.host/ for 443
https://your.host:4443/ for 4443

only to be sure this is what you had in mind ...
jake-
 
Posts: 31
Joined: 21 Jun 2013, 16:42
Has thanked: 15 times
Been thanked: 18 times

Re: https does not work

Unread postby illumilore » 21 Dec 2015, 00:56

4443 is what I set the https port to be in /etc/sysconfig/madsonic, since 443 is already used. I have checked the firewall to make sure that is open. In the madsonic_sh.log, there is no mention of it running on port 4443, only on 4040.
illumilore
 
Posts: 7
Joined: 17 Aug 2015, 23:59
Has thanked: 0 time
Been thanked: 3 times


Return to Bug Reports 5.x

Who is online

Users browsing this forum: No registered users and 1 guest