Multi-Disc Albums not displaying correctly

Post your Server Bug Report

Multi-Disc Albums not displaying correctly

Unread postby gurutech » 14 Nov 2013, 02:43

I have a TON of multi-disc albums, and none of them display correctly, despite the id3 tag being correct!

For example, I have Nine Inch Nails - Hesitation Marks [Deluxe Edition] Disk 1, and Disk 2. They display as "Nine Inch Nails - Nine Inch Nails - Disk 1" and Disk 2.

Since I have multiple multi-disc sets from the same artist, all of them display with the artist name twice.

Any idea how to fix this, or can this be looked into for the next release?
gurutech
Contributor
Contributor
 
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 12 times
Been thanked: 130 times

Re: Multi-Disc Albums not displaying correctly

Unread postby lamor » 26 Aug 2014, 21:25

Same problem.
No answer so no solution ?

My folder structure when multi disc is
Artist--Album (Disc1)
|
---Album (Disc2)

I came from subsonic 4.7 and it's ok with this.
lamor
 
Posts: 1
Joined: 26 Aug 2014, 10:17
Has thanked: 0 time
Been thanked: 0 time

Re: Multi-Disc Albums not displaying correctly

Unread postby Madevil » 05 Sep 2014, 20:53

lamor wrote:Same problem.
No answer so no solution ?

My folder structure when multi disc is
Artist--Album (Disc1)
|
---Album (Disc2)

I came from subsonic 4.7 and it's ok with this.


Hi there,

you have 2 options

1. Solution

use other directory structure

Code: Select all
ARTIST -- ALBUMSET
                |   
                |-- ALBUM DISK1
                |-- ALBUM DISK2


2. Solution

change in general settings -> Disable AlbumSet/Folder Parsing.
make a full rescan to read the new structure.

best regards
User avatar
Madevil
Administrator
Administrator
 
Posts: 911
Joined: 07 Dec 2012, 03:58
Has thanked: 1324 times
Been thanked: 951 times


Return to Bug Reports 5.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron