Madsonic Server 5.0 unRAID Plugin

Re: Madsonic Server 5.0 unRAID Plugin

Unread postby Lars » 05 Jul 2014, 23:41

btd wrote:Hi, just dropped by to ask: any plans for unraid 6 (64bit) plugin? I tried to install latest madsonic plugin, it installs ok, but cant start and gives:
"Warning: file_get_contents(/boot/config/plugins/madsonic/version.txt): failed to open stream: No such file or directory in /usr/local/emhttp/plugins/webGui/include/myPage_content.php(64) : eval()'d code on line 117"

same "warning" here in the unraid gui, but it starts just fine.

Cheers, L
Lars
Contributor
Contributor
 
Posts: 36
Joined: 01 Jul 2014, 23:06
Location: Jamaica
Has thanked: 30 times
Been thanked: 29 times

Re: Madsonic Server 5.0 unRAID Plugin

Unread postby Lars » 06 Jul 2014, 01:07

hi,

i just updated my unraid to v6-beta6 (clean new install) and installed madsonic-5.0-1.6-x64-jetty8.

first of all, thx for a great plugin! alone the working genre feature is worth the switch from subsonic! other features make it even more worthwhile. a great job to put subsonic on steroids :)

anyway, some probs remain, due to clean install i can't see them coming from updated installs. my programming skills are rather on the mediocre end of the scale, so i most likely will be of little help there. i am pretty good following guides and not afraid to get into the files, settings etc. to change stuff around. in so far, any help is highly appreciated and i am happy to volunteer myself and my server to experiments in order to improve things :D

getting down to the issues on my end now:

1- first of all, after installing above mentioned file, i noticed that the about madsonic page says my install is v5.0.3860 instead of ...3880 - strange! it points out as well that ...3880 is available. (one thing here i like to suggest - instead of naming the unraid and stand alone differently - really causes confusion - why not name them the same for the version numbers, the filetype makes it clear enough what it is for)

2- the last.fm part is still crashing for me

3- it seems that i can't set a max bitrate (audio) for users, defaults always back to unlimited

4- (that's a huge issue for me at the moment) flac (maybe other formats as well, didn't get that far yet) will not play in webplayer. i noticed the comment to set to default subsonic for transcoding, but no difference.

there might be other issues as well, once again - i didn't get that far yet. as i discover more i will update the list here.
any kind of help/ solutions will be highly appreciated.

cheers, L
Lars
Contributor
Contributor
 
Posts: 36
Joined: 01 Jul 2014, 23:06
Location: Jamaica
Has thanked: 30 times
Been thanked: 29 times

Re: Madsonic Server 5.0 unRAID Plugin

Unread postby Lars » 08 Jul 2014, 00:01

Lars wrote:hi,

i just updated my unraid to v6-beta6 (clean new install) and installed madsonic-5.0-1.6-x64-jetty8.

first of all, thx for a great plugin! alone the working genre feature is worth the switch from subsonic! other features make it even more worthwhile. a great job to put subsonic on steroids :)

anyway, some probs remain, due to clean install i can't see them coming from updated installs. my programming skills are rather on the mediocre end of the scale, so i most likely will be of little help there. i am pretty good following guides and not afraid to get into the files, settings etc. to change stuff around. in so far, any help is highly appreciated and i am happy to volunteer myself and my server to experiments in order to improve things :D

getting down to the issues on my end now:

1- first of all, after installing above mentioned file, i noticed that the about madsonic page says my install is v5.0.3860 instead of ...3880 - strange! it points out as well that ...3880 is available. (one thing here i like to suggest - instead of naming the unraid and stand alone differently - really causes confusion - why not name them the same for the version numbers, the filetype makes it clear enough what it is for)

2- the last.fm part is still crashing for me

3- it seems that i can't set a max bitrate (audio) for users, defaults always back to unlimited

4- (that's a huge issue for me at the moment) flac (maybe other formats as well, didn't get that far yet) will not play in webplayer. i noticed the comment to set to default subsonic for transcoding, but no difference.

there might be other issues as well, once again - i didn't get that far yet. as i discover more i will update the list here.
any kind of help/ solutions will be highly appreciated.

cheers, L


Update 1

1- after reinstalling it suddenly became version 3880, i deleted the madsonic folder on my cache drive before, something i did forget before initial install. i assume that was the problem.

2- re last.fm: found post re. last.fm in the forum - based on that i guess it wont be fixed for now (solves that point for the moment)

3- still the same

4- after going to my install, it looks like there is nothing installed in the madsonic/transcode directory, which strikes me as odd. wouldn't that be the directory where i would find the installed ffmpeg files????

cheers, L


Update 2

1-3- no change

4- solved the transcoding issue with the following:

1) added: <FILE Name="/boot/packages/ffmpeg-2.1.3-x86_64-1sl.txz" Run="upgradepkg --install-new">
<URL>http://unraid-madsonic-plugin.googlecode.com/svn/trunk/ffmpeg-2.1.3-x86_64-1sl.txz</URL>
</FILE>
to madsonic-5.0-1.6-x64-jetty8.plg script and run a reinstall.

now you should find <ffmpeg-2.1.3-x86_64-1sl.txz> installed in your /boot/packages folder

2)added the content of the linux folder from <20140702_madsonic-transcode_latest_x64> package to my /cache/.apps/madsonic/transcode directory.

i just restarted the server at this point to make sure its all there/ poss not really needed.
works fine sofar with: Reset Transcoding profil to Subsonic Default, other settings i haven't tested yet. but it should hopefully work as well. i have only music, so i can attest for flac, aiff, wav,ape streaming properly over the webplayer for me.


hope that helps somebody else with the same problem.

cheers, L
Lars
Contributor
Contributor
 
Posts: 36
Joined: 01 Jul 2014, 23:06
Location: Jamaica
Has thanked: 30 times
Been thanked: 29 times

Re: Madsonic Server 5.0 unRAID Plugin

Unread postby monq » 11 Jan 2015, 03:39

Just wanted to say thanks to all for the excellent work.

Also, after updating unRAID to latest stable 5.06 can't seem to install madsonic unRAID plugin. Have tried each of the following:
1. madsonic-5.2-2.0-x86.plg
2. madsonic-5.0-1.6-x86-jetty8.plg
3. madsonic-5.0-1.6-x86-jetty6.plg


get following error/s:

Warning: simplexml_load_file(): madsonic-5.2-2.0-x86.plg:4406: parser error : Premature end of data in tag link line 13 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): madsonic-5.2-2.0-x86.plg:4406: parser error : Premature end of data in tag meta line 11 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): in /usr/local/sbin/installplg on line 13
monq
 
Posts: 1
Joined: 28 Mar 2013, 10:52
Has thanked: 0 time
Been thanked: 2 times

Previous

Return to UnRAID

Who is online

Users browsing this forum: No registered users and 1 guest