Madsonic Server 5.x Synology-DSM 5.x NAS Plugin

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby manau » 17 Nov 2014, 09:46

manau wrote:i am running madsonic 5.2.5300 in my syno DS1512+ it is running perferct beside one thing which im not able to figure out.
the upload function is not working im always receiving a permissionn denied. i know this is a permisssion issue but cant understand where. as dowloading album covers and put them into the album folder works fine and i think is done wtih the same permission or user.
could someone give me a hint where to look into or what to change?


was able to solve it on my own. had just to chmod the rights of the incoming folder to 776.
manau
 
Posts: 0
Joined: 09 Nov 2014, 13:20
Has thanked: 0 time
Been thanked: 1 time

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby olive069 » 18 Dec 2014, 10:39

Can someone make a Madsonic spk for ARMv5 with Madsonic 5.2 Beta2??

thanks.
User avatar
olive069
 
Posts: 14
Joined: 03 Dec 2013, 15:53
Has thanked: 9 times
Been thanked: 10 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby lionelkw » 18 Dec 2014, 10:56

Hello all,
Yet another transcode error: I can't read anything else than mp3 on the server, with Serviio and all installed. When I get to the transcode dir in the Madsonic dir, I do see ffmpeg and typing the command ffmpeg seems to work. Has anyone solved such a problem?
lionelkw
 
Posts: 0
Joined: 29 Jan 2014, 15:18
Has thanked: 1 time
Been thanked: 1 time

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby st3ffen » 08 Jan 2015, 09:57

Works fine @ DSM 5.1 / DS413 :) .
Does anyone use the Jukebox function?
java audioDevList didnt found any mixer :(
st3ffen
 
Posts: 1
Joined: 07 May 2014, 06:02
Has thanked: 0 time
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby lionelkw » 08 Jan 2015, 10:24

@St3ffen Did transcoding work out of the box? With no special mods or tricks to have ffmpeg behave?
lionelkw
 
Posts: 0
Joined: 29 Jan 2014, 15:18
Has thanked: 1 time
Been thanked: 1 time

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby st3ffen » 08 Jan 2015, 17:27

Yes, with no changes. But i've only tested with flac audio files. I've installed the following apps. And i wonder myself that Serviio is not installed and it works anyway :0.
Last edited by st3ffen on 19 Jan 2015, 19:56, edited 1 time in total.
st3ffen
 
Posts: 1
Joined: 07 May 2014, 06:02
Has thanked: 0 time
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby lionelkw » 08 Jan 2015, 20:16

Thanks a bunch. That's... very weird. I tried everything I could think of, installing all those, SSH'ing symlinks and even copying ffmpeg to Madsonic directories, nothing works.
lionelkw
 
Posts: 0
Joined: 29 Jan 2014, 15:18
Has thanked: 1 time
Been thanked: 1 time

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby st3ffen » 09 Jan 2015, 17:28

Ok, now i've a the problem @ my new DS415+. Trancode on Madsonic doesn't work.
The reason for that is certainly that the surviio package doesn't exists for my 415+.
Now my question:
-Is it possible to use the ffmpeg package which is allready installed by "Audio Station" ?
Code: Select all
DiskStation> find /* |grep ffmpeg
/usr/syno/bin/ffmpeg-thumb
/usr/syno/bin/ffmpeg
/volume1/@appstore/AudioStation/bin/ffmpeg
/volume1/@appstore/AudioStation/lib/ffmpeg
/volume1/@appstore/AudioStation/lib/ffmpeg/libavresample.so.1
/volume1/@appstore/AudioStation/lib/ffmpeg/libavformat.so.55
/volume1/@appstore/AudioStation/lib/ffmpeg/libswresample.so.0
/volume1/@appstore/AudioStation/lib/ffmpeg/libavutil.so.52
/volume1/@appstore/AudioStation/lib/ffmpeg/libavcodec.so.55
/volume1/@appstore/AudioStation/lib/ffmpeg/libavdevice.so.55
/volume1/@appstore/AudioStation/lib/ffmpeg/libswscale.so.2
/volume1/@appstore/AudioStation/lib/ffmpeg/libavfilter.so.3
/volume1/@appstore/Madsonic/transcode/ffmpeg
DiskStation>



This is my "find" output on my DS413:
Code: Select all
Server> find * / |grep ffmpeg
find: *: No such file or directory
/usr/syno/bin/ffmpeg-thumb
/usr/syno/bin/ffmpeg
/volume1/@appstore/SurveillanceStation/lib/ffmpeg
/volume1/@appstore/SurveillanceStation/lib/ffmpeg/libswscale.so.2
/volume1/@appstore/SurveillanceStation/lib/ffmpeg/libswresample.so.0
/volume1/@appstore/SurveillanceStation/lib/ffmpeg/libavformat.so.54
/volume1/@appstore/SurveillanceStation/lib/ffmpeg/libavutil.so.51
/volume1/@appstore/SurveillanceStation/lib/ffmpeg/libavcodec.so.54
/volume1/@appstore/Serviio/bin/ffmpeg-wrapper.sh
/volume1/@appstore/Serviio/bin/ffmpeg
/volume1/@appstore/Subsonic/transcode/ffmpeg
/volume1/@appstore/DVBLinkServer/common/ffmpeg
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libavfilter.so.3
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libswresample.so.0
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libavformat.so.54
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libavdevice.so.54
/volume1/@appstore/DVBLinkServer/common/ffmpeg/ffmpeg
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libshine.so.1
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libswscale.so.2
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libavutil.so.51
/volume1/@appstore/DVBLinkServer/common/ffmpeg/make_thumbnail.sh
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libavcodec.so.54
/volume1/@appstore/DVBLinkServer/common/ffmpeg/libpostproc.so.52
/volume1/@appstore/VideoStation/bin/ffmpeg
/volume1/@appstore/VideoStation/bin/cffmpeg
/volume1/@appstore/VideoStation/lib/ffmpeg
/volume1/@appstore/VideoStation/lib/ffmpeg/libavformat.so.55
/volume1/@appstore/VideoStation/lib/ffmpeg/libswresample.so.0
/volume1/@appstore/VideoStation/lib/ffmpeg/libavutil.so.52
/volume1/@appstore/VideoStation/lib/ffmpeg/libavcodec.so.55
/volume1/@appstore/VideoStation/lib/ffmpeg/libavdevice.so.55
/volume1/@appstore/VideoStation/lib/ffmpeg/libswscale.so.2
/volume1/@appstore/VideoStation/lib/ffmpeg/libavfilter.so.3
/volume1/@appstore/VideoStation/lib/ffmpeg/libpostproc.so.52
/volume1/@appstore/Madsonic/transcode/ffmpeg


And if anyone has any ideas for my other problem ;)

DiskStation> java audioDevList
Available mixers:
DiskStation>
st3ffen
 
Posts: 1
Joined: 07 May 2014, 06:02
Has thanked: 0 time
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby st3ffen » 24 Jan 2015, 11:39

Transcoding works :)

First: Its not necessary to install Serviio.(but it worked with the arch = avoton)

My Steps:
Code: Select all
cd /volume1/@appstore/Madsonic/
mv transcode/ transcode1/
mkdir transcode
chown madsonic:users transcode/
ln -s /volume1/@appstore/AudioStation/bin/ffmpeg  transcode/
cd transcode
ll
DiskStation> ll
drwxr-xr-x    2 madsonic users         4096 Jan 24 11:25 .
drwxr-xr-x   11 madsonic users         4096 Jan 24 11:37 ..
lrwxrwxrwx    1 root     root            42 Jan 24 11:25 ffmpeg -> /volume1/@appstore/AudioStation/bin/ffmpeg
DiskStation>

Best Regards
st3ffen
st3ffen
 
Posts: 1
Joined: 07 May 2014, 06:02
Has thanked: 0 time
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby lionelkw » 30 Jan 2015, 21:54

AWESOME, dude! It's working flawlessly! Thank you so much!
lionelkw
 
Posts: 0
Joined: 29 Jan 2014, 15:18
Has thanked: 1 time
Been thanked: 1 time

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby Siutsch » 05 Feb 2015, 22:16

@steffen

I tried that too, but can only play music.

In Browser (FF) I always get:
Error loading media:
File could not ne played!

I really don't know why. :(

I use Madsonic 5.2 in a Synology 1813+

Do you have an idea, what I'm doing wrong?


EDIT: With DSub on my Samsung S4 I can play videos too.
Only with Browser it's not working.
Thankz,
Siutsch.
Siutsch
 
Posts: 9
Joined: 14 Mar 2013, 11:30
Has thanked: 2 times
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby jaszladie » 19 Feb 2015, 23:05

I've tried both versions of Madsonic (5.0 and 5.1) that are in the first post of this thread.

Both of them gave me the user authentication error. The user has been deleted, but the error still fills the log file.

How do I stop this error?

Update: Somehow this is resolved. I have stopped the service though due to other issues. I hope to come back. Madsonic is my favorite.
Last edited by jaszladie on 25 Feb 2015, 17:59, edited 1 time in total.
jaszladie
 
Posts: 15
Joined: 31 Oct 2013, 17:16
Has thanked: 22 times
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby z-vap » 20 Feb 2015, 01:26

(nvm I will move this to another spot in the forums)
z-vap
 
Posts: 21
Joined: 08 Jun 2013, 12:36
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby FoxBJK » 22 Feb 2015, 16:18

mwills wrote:i have a synology ds1812+ (intel) with Jave SE Embedded 6, Perl, and Serviio packages installed.

i try to do a manual install with the Madsonic5.1-B5080-017.spk or Madsonic5.1-B5060-016.spk and i continue to get the same error:

Operation Failed

Cannot find a folder named 'Madsonic' in your public folder. Please check your public folder and make sure there is a folder called Madsonic (with capital M) in it. Or select 'No' if you don't want to restore anything and just install Madsonic normally.


i get this error even when selecting 'No' during install to 'restore a backup'. what am i missing?


I'm getting this same error on my DS414j, and the logs aren't showing anything other than "Failed to install package [Madsonic]." Please help! I tried creating a share called Madsonic, a share called public, tried putting Madsonic inside my main share, all nothing! I'm stuck, and without descriptive errors I have no clue where to turn.

Thanks!
FoxBJK
 
Posts: 2
Joined: 22 Feb 2015, 15:23
Has thanked: 1 time
Been thanked: 2 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby z-vap » 26 Feb 2015, 13:18

just a shot in the dark, but do you have /volume1/public/Madsonic
z-vap
 
Posts: 21
Joined: 08 Jun 2013, 12:36
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic Server 5.x Synology-NAS Plugin

Unread postby muiz » 21 Aug 2015, 19:44

How do i manualy update to 6.0 ?
muiz
 
Posts: 19
Joined: 13 Jan 2013, 01:36
Has thanked: 4 times
Been thanked: 3 times

Re: Madsonic Server 5.0 Synology-NAS Plugin

Unread postby sbistvan » 23 Aug 2015, 20:06

softsmoke wrote:I updated my DSMm then I get this problem. I tryed to reinstalled without any luck. Can someone help me?

HTTP ERROR: 503

Problem accessing /index.view. Reason:

Service Unavailable

Powered by Jetty://

/softsmoke


I'm having the exact same issue. Does anybody know the solution to this one?
Thanks in advance!

EDIT: restarting the service in DSM solved the problem
sbistvan
 
Posts: 0
Joined: 26 Nov 2014, 21:53
Has thanked: 0 time
Been thanked: 1 time

Re: Madsonic Server 5.0 Synology-NAS Plugin

Unread postby keysuck » 10 Sep 2015, 06:48

If anyone is interested, I compiled SPK for version 6.0.7460.4537066. (UPDATE: 9/18/2005)

https://goo.gl/LXbzRa
MD5 Sum: b79f9a339abde2931eadf39515d54b02

I merely extracted SPK from the original post, updated VERSION, madsonic.sh, madsonic.war and madsonic-booter.jar and repackaged it.

sbistvan wrote:
softsmoke wrote:I updated my DSMm then I get this problem. I tryed to reinstalled without any luck. Can someone help me?

HTTP ERROR: 503

Problem accessing /index.view. Reason:

Service Unavailable

Powered by Jetty://

/softsmoke


I'm having the exact same issue. Does anybody know the solution to this one?
Thanks in advance!

EDIT#1: restarting the service in DSM solved the problem


Stop service, rename 'db' folder (e.g. 'db.old') and start service to recreate db.

EDIT#2: Madsonic icon is missing from the menu. Access via URL is necessary. Hope the dev releases an official (error-free!) update.

EDIT#3: Icon is now visible in the menu. (9/18/2015)
Last edited by keysuck on 18 Sep 2015, 09:45, edited 2 times in total.
keysuck
 
Posts: 0
Joined: 27 Mar 2015, 09:20
Has thanked: 1 time
Been thanked: 6 times

Re: Madsonic Server 5.0 Synology-NAS Plugin

Unread postby z-vap » 12 Sep 2015, 17:06

keysuck wrote:If anyone is interested, I compiled SPK for version 6.0.7200.

https://goo.gl/fYYqsn
2d8529161ceff96588e6b92ef851dfdf

I merely extracted SPK from the original post, updated VERSION, madsonic.sh, madsonic.war and madsonic-booter.jar and repackaged it.


Thanks dude. I really need to start learning how to create my own SPK files. Any advice or links to some good info?

EDIT: I also would like to figure out a way to integrate the ffmpeg into this. I see there is trhe Serviio native x86 etc. But I don't know how to obtain new files for madsonic

EDIT2: I tried making my own package for 5.1.5260 and it would not install for me. Not sure why. :( The 6.0 package referenced above did work.
z-vap
 
Posts: 21
Joined: 08 Jun 2013, 12:36
Has thanked: 4 times
Been thanked: 4 times

Re: Madsonic Server 5.0 Synology-NAS Plugin

Unread postby baker2gs » 13 Sep 2015, 13:43

keysuck wrote:If anyone is interested, I compiled SPK for version 6.0.7200.

https://goo.gl/fYYqsn
2d8529161ceff96588e6b92ef851dfdf

I merely extracted SPK from the original post, updated VERSION, madsonic.sh, madsonic.war and madsonic-booter.jar and repackaged it.

sbistvan wrote:
softsmoke wrote:I updated my DSMm then I get this problem. I tryed to reinstalled without any luck. Can someone help me?

HTTP ERROR: 503

Problem accessing /index.view. Reason:

Service Unavailable

Powered by Jetty://

/softsmoke


I'm having the exact same issue. Does anybody know the solution to this one?
Thanks in advance!

EDIT: restarting the service in DSM solved the problem


Stop service, rename 'db' folder (e.g. 'db.old') and start service to recreate db.


Where is the db folder? I can't seem to find it. Also, looks like there is no icon in the app menu?
baker2gs
 
Posts: 0
Joined: 21 Jul 2014, 02:59
Has thanked: 4 times
Been thanked: 0 time

PreviousNext

Return to Synology

Who is online

Users browsing this forum: No registered users and 2 guests