Madsonic 5.1 FreeNAS PBI

Madsonic 5.1 FreeNAS PBI

Unread postby Madevil » 20 Aug 2014, 15:07

User avatar
Madevil
Administrator
Administrator
 
Posts: 921
Joined: 07 Dec 2012, 03:58
Has thanked: 1305 times
Been thanked: 956 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 22 Aug 2014, 15:21

I am unable to start the plugin. I setup a plugins jail and installed the PBI but it refuses to start. I am running Freenas 9.2.1.7, please advise.

Also the link on this post to download the PBI is for Synology not Freenas.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby Madevil » 22 Aug 2014, 19:41

raidflex wrote:I am unable to start the plugin. I setup a plugins jail and installed the PBI but it refuses to start. I am running Freenas 9.2.1.7, please advise.
Also the link on this post to download the PBI is for Synology not Freenas.


Hi there,

Thanks, update download link!

maybe you forgot some requirements, please follow and recheck this steps

  • new FreeNAS 9.2.1.7 installation
  • create new ZFS Volume -> example: Storage
  • create new ZFS Dataset -> example: public for media
  • create new ZFS Dataset -> example: pluginjails
  • edit ZFS Dataset Security -> check write for group other
  • configure Jails path to the new created dataset pluginjails
  • install Madsonic package
  • configure plugin
  • start plugin
  • done!

2014-08-22 20_36_35-freenas - FreeNAS-9.2.1.7-RELEASE-x64 (fdbe9a0).png

2014-08-22 20_37_29-freenas - FreeNAS-9.2.1.7-RELEASE-x64 (fdbe9a0).png



best regards
User avatar
Madevil
Administrator
Administrator
 
Posts: 921
Joined: 07 Dec 2012, 03:58
Has thanked: 1305 times
Been thanked: 956 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 22 Aug 2014, 20:18

Madevil wrote:
raidflex wrote:I am unable to start the plugin. I setup a plugins jail and installed the PBI but it refuses to start. I am running Freenas 9.2.1.7, please advise.
Also the link on this post to download the PBI is for Synology not Freenas.


Hi there,

Thanks, update download link!

maybe you forgot some requirements, please follow and recheck this steps

  • new FreeNAS 9.2.1.7 installation
  • create new ZFS Volume -> example: Storage
  • create new ZFS Dataset -> example: public for media
  • create new ZFS Dataset -> example: pluginjails
  • edit ZFS Dataset Security -> check write for group other
  • configure Jails path to the new created dataset pluginjails
  • install Madsonic package
  • configure plugin
  • start plugin
  • done!

2014-08-22 20_36_35-freenas - FreeNAS-9.2.1.7-RELEASE-x64 (fdbe9a0).png

2014-08-22 20_37_29-freenas - FreeNAS-9.2.1.7-RELEASE-x64 (fdbe9a0).png



best regards


The only difference I had was I did not change the permissions for the jail Dataset, but even after changing the permission the plugin will still not start. I also had a similar problem with Tech Demo III when I overwrote the Subsonic plugin jar/war files. If I overwrote the jar/war files with TD II's then the plugin would start without issue, not sure if this is related.

The problem seems like a permissions issue, but I am not sure.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 15 Sep 2014, 00:27

I figured out the problem. For some reason the "media" group/user was not being created in the jail. I created a new "media" user/group with the proper UID and the plugin started successfully.

But now I have the same problem of no web access. The plugin starts but the web GUI is not accessible. This is the same issue I had with Tech Demo III. I found previous by moving back to TD II the issue went away.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 24 Sep 2014, 23:53

Nope I still have the same issue. I have no issues with any other plugins including Subsonic. I also am not sure if the PBI has been updated to 5.1 Final.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 25 Sep 2014, 21:18

jayd wrote:Same here. I believe the issue is related to permissions. I'm on UFS *eh my media server only has 4 gig ram*.


Yeah I suspect its a permissions issue also, but after looking through everything it seems correct. I am using ZFS.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 03 Oct 2014, 19:37

Which user does the plugin run as Madevil?

Edit: Well it looks like After upgrading to Freenas 9.2.1.8 my problem has been solved. All I did after updating Freenas was to remove the Madsonic plugin and re-install it and its working properly now. I even updated the jar files to the Final version successfully. Thanks Madevil for a great product.
Last edited by raidflex on 03 Oct 2014, 20:23, edited 1 time in total.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: AW: Madsonic 5.1 FreeNAS PBI

Unread postby Madevil » 03 Oct 2014, 20:21

Run as user media
User avatar
Madevil
Administrator
Administrator
 
Posts: 921
Joined: 07 Dec 2012, 03:58
Has thanked: 1305 times
Been thanked: 956 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby raidflex » 06 Oct 2014, 14:58

darthanubis wrote:What if these steps are already done, because the luxury to a fresh install of Freenas one does not have?

new FreeNAS 9.2.1.7 installation
create new ZFS Volume -> example: Storage
create new ZFS Dataset -> example: public for media
create new ZFS Dataset -> example: pluginjails
edit ZFS Dataset Security -> check write for group other
configure Jails path to the new created dataset pluginjails

I have tried to create a jail
give it the correct permissions
add storage to the jail
install the plugin
configure the plugin
start the plugin

Yet the plugin fails repeatedly without an error that I can tell.

Is a fresh install mandatory? Or is there a way to plugin this plugin in to a running system :?:


Have you updated to Freenas 9.2.1.8 and then reinstalled the plugin? This is what fixed the same problem for me.
raidflex
 
Posts: 14
Joined: 29 Apr 2013, 21:47
Has thanked: 0 time
Been thanked: 7 times

Re: Madsonic 5.1 FreeNAS PBI

Unread postby josh4trunks » 17 Oct 2016, 02:32

Hey thanks for developing Madsonic.

I built v6.0 of the plugin using the FreeBSD madsonic-standalone port. My source for the plugin can be found at..
https://github.com/josh4trunks/freenas- ... s/madsonic

It should be availabe from the FreeNAS repo tomorrow.
josh4trunks
Contributor
Contributor
 
Posts: 1
Joined: 22 May 2014, 16:14
Has thanked: 0 time
Been thanked: 2 times


Return to FreeNAS

Who is online

Users browsing this forum: No registered users and 1 guest

cron