Madsonic Server 5.x KODI Plugin

Madsonic Server 5.x KODI Plugin

Unread postby Madevil » 13 Dec 2014, 02:02

Image

Madsonic KODI Plugin

http://xbmc.org/


Contribution: http://forum.xbmc.org/showthread.php?tid=99513 developed by t0mm0

0.5.5:
  • Update for Build 5400

don't forget to set up your server info in the plugin settings.
by default it points at the demo server (http://demo.subsonic.org) so you can try it out of the box.

you might get better results if you force using DVDPlayer.
if you don't already have a playercorefactory.xml in your userdata directory then make a file and add the following in it.


Code: Select all
<playercorefactory>
    <rules action="prepend">
        <rule name="madsonic" filename=".*/rest/(stream|download).view.*" player="dvdplayer"/>
    </rules>
</playercorefactory>


if you already have one, just insert the line:

Code: Select all
<rule name="madsonic" filename=".*/rest/(stream|download).view.*" player="dvdplayer"/>

directly after the <rules> tag.

see http://wiki.xbmc.org/index.php?title=HO ... a_playback for more info on playercorefactory.xml

Download

plugin.audio.madsonic.0.5.5.zip
(242.44 KiB) Downloaded 321 times

plugin.video.madsonic.0.5.5.zip
(242.42 KiB) Downloaded 156 times


Screenshot

2014-12-13 01_21_24-Kodi.png

2014-12-13 01_22_03-Kodi.png

2014-12-13 01_22_26-Kodi.png

2014-12-13 01_39_03-Kodi.png


best regards
User avatar
Madevil
Administrator
Administrator
 
Posts: 913
Joined: 07 Dec 2012, 03:58
Has thanked: 1331 times
Been thanked: 952 times

Re: Madsonic Server KODI Plugin

Unread postby DoCC » 15 Dec 2014, 21:17

Nice idea, but ...
why should somebody install a mediamanager within an mediamanager ?
this is confusing to me : )
User avatar
DoCC
Contributor
Contributor
 
Posts: 210
Joined: 25 Feb 2014, 14:41
Location: UpperBavaria : ))
Has thanked: 41 times
Been thanked: 71 times

Re: Madsonic Server KODI Plugin

Unread postby skopo » 18 Dec 2014, 08:30

Song changing problem from XBMC Gotham remains.

Set play album -> 1st song no problems -> 2nd song not found -> 3rd not found -> rolls same way to the end of the album.
skopo
Contributor
Contributor
 
Posts: 69
Joined: 07 Apr 2013, 07:48
Has thanked: 11 times
Been thanked: 20 times

Re: Madsonic Server KODI Plugin

Unread postby jmode » 06 Jan 2015, 04:07

Hi,

I would really love to use this add on in KODI but I keep getting the following error:

Incompatible Subsonic REST protocol version. Server must upgrade.

I get the error with both the demo server and my server.

Any suggestions?

Thanks!
jmode
 
Posts: 0
Joined: 17 Dec 2014, 14:22
Has thanked: 0 time
Been thanked: 1 time

Re: Madsonic Server KODI Plugin

Unread postby oxias » 07 Jan 2015, 14:05

jmode wrote:Hi,

I would really love to use this add on in KODI but I keep getting the following error:

Incompatible Subsonic REST protocol version. Server must upgrade.

I get the error with both the demo server and my server.

Any suggestions?

Thanks!


Same problem reported, with a Subsonic server. I tried with a Madsonic Techdemo v5.1, but the add-on says 'time out"...
oxias
 
Posts: 3
Joined: 08 Dec 2014, 00:32
Has thanked: 0 time
Been thanked: 1 time

Re: Madsonic Server KODI Plugin

Unread postby grungybob » 08 Apr 2015, 19:23

skopo wrote:Song changing problem from XBMC Gotham remains.

Set play album -> 1st song no problems -> 2nd song not found -> 3rd not found -> rolls same way to the end of the album.



Hi everyone, same problem for me (openelec - Kodi 14.2 / MADSONIC 5.1.5200.20141017.1252).
grungybob
 
Posts: 0
Joined: 12 May 2013, 18:29
Has thanked: 0 time
Been thanked: 1 time

Re: Madsonic Server KODI Plugin

Unread postby cwalk » 14 Apr 2015, 04:09

I can use plugin.video.madsonic to play audio fine, but when I play video it will hang. Thoughts?
cwalk
 
Posts: 1
Joined: 10 Jan 2014, 21:05
Has thanked: 8 times
Been thanked: 0 time

Re: Madsonic Server KODI Plugin

Unread postby slonlo » 14 Apr 2015, 19:17

cwalk wrote:I can use plugin.video.madsonic to play audio fine, but when I play video it will hang. Thoughts?

I'm having the same issue. Are you using Lollipop? I've had the problem ever since I upgraded. I have an app that has video problems too, and I wondered if it's related. Haven't delved into it too deeply though.
slonlo
 
Posts: 0
Joined: 17 Apr 2014, 05:41
Has thanked: 0 time
Been thanked: 0 time

Re: Madsonic Server KODI Plugin

Unread postby cwalk » 15 Apr 2015, 22:45

slonlo wrote:Are you using Lollipop?


Nope. This happens on my KODI install for both Amazon Fire TV (based on 4.4.2?) and Windows. I haven't tried any other OSes.

What I do find interesting is that if I set transcode to false in plugin.video.madsonic\resources\settings.xml then I can play videos. Unfortunately, since I'm playing a RAW video, KODI/my network cannot keep up.

This leads me to believe that video transcoding is to blame, but I have no idea how to further debug.
cwalk
 
Posts: 1
Joined: 10 Jan 2014, 21:05
Has thanked: 8 times
Been thanked: 0 time


Return to KODI

Who is online

Users browsing this forum: No registered users and 1 guest