LDAP authentication not supported by Madsonic 5.7.364

Post your Client Bug Report

LDAP authentication not supported by Madsonic 5.7.364

Unread postby troycarpenter » 04 Sep 2015, 00:13

Code: Select all
=========================================================================================
 VERSION:      MADSONIC 6.0 | BUILD: 7150
 SERVLET:      JETTY 8.y.z-SNAPSHOT
 SERVER:       CPU: AMD
 OS:           Linux MINT (DEBIAN/Ubuntu)
 SYSTEM:       CLIENT
 INSTALLER:    DEB | RPM | DOCKER | OTHER
 JAVA:         1.7.0_79
 BROWSER:      CHROME 44
 CLIENT:       MADSONIC 5.7
 DESCRIPTION:  LDAP not supported
 REPRODUCIBLE: YES
=========================================================================================


I'm using this against Madsonic 6.0. I've configured LDAP, and the profile I'm using on the Android app is an LDAP user.

When I test the connection in the server configuration screen, it says:

"Connection Failure. LDAP passthrough authentication not supported."

In the madsonic.log file, I see:
DEBUG MadsonicLdapBindAuthenticator - User 'fred' successfully authenticated in LDAP. DN: uid=fred,ou=People

Will the Android app support LDAP? Not helpful if not because all my users are LDAP users.
User avatar
troycarpenter
 
Posts: 120
Joined: 03 Dec 2013, 19:16
Location: Georgia, USA
Has thanked: 19 times
Been thanked: 50 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby Madevil » 04 Sep 2015, 00:50

Thanks for reporting,

many builds before i implemented some new LDAP features and authentication changes and must be temp. disabled,
this can now be changed, refactoring come with next builds.

best regards
User avatar
Madevil
Administrator
Administrator
 
Posts: 926
Joined: 07 Dec 2012, 03:58
Has thanked: 1317 times
Been thanked: 959 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby troycarpenter » 04 Sep 2015, 15:49

Is the change to support this on the client or on the server? I've put in requests for both Jamstash and Dsub to support the new API version, but I would want to give them a heads-up if there is something on the client needed to support this. However, I wouldn't expect the client to need to know the server's backend authentication model.
User avatar
troycarpenter
 
Posts: 120
Joined: 03 Dec 2013, 19:16
Location: Georgia, USA
Has thanked: 19 times
Been thanked: 50 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby Madevil » 04 Sep 2015, 15:51

next Build 7200 comes with some LDAP enhancements and also the client problem is fixed.

best regards
User avatar
Madevil
Administrator
Administrator
 
Posts: 926
Joined: 07 Dec 2012, 03:58
Has thanked: 1317 times
Been thanked: 959 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby troycarpenter » 06 Sep 2015, 23:23

Using 7200, the client doesn't give the passthrough message anymore. Instead, it can't authenticate the LDAP user at all now. The app says " Connection failure. Wrong username or password". The madsonic log says "Login failed" for user. I can successfully log into the web interface with the same user credentials.
User avatar
troycarpenter
 
Posts: 120
Joined: 03 Dec 2013, 19:16
Location: Georgia, USA
Has thanked: 19 times
Been thanked: 50 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby drashna » 30 Sep 2015, 15:38

troycarpenter wrote:Using 7200, the client doesn't give the passthrough message anymore. Instead, it can't authenticate the LDAP user at all now. The app says " Connection failure. Wrong username or password". The madsonic log says "Login failed" for user. I can successfully log into the web interface with the same user credentials.


I'm seeing this with ALL users on the mobile app, not jus LDAP. Have you tried making sure it's not just the LDAP authenticated users?
drashna
 
Posts: 10
Joined: 05 Jul 2013, 19:58
Has thanked: 0 time
Been thanked: 4 times

Re: LDAP authentication not supported by Madsonic 5.7.364

Unread postby frank2228 » 01 Dec 2016, 07:17

Using 7200, the client doesn't give the passthrough message anymore. Instead, it can't authenticate the LDAP user at all now. The app says " Connection failure. Wrong username or password". The madsonic log says "Login failed" for user. I can successfully log into the web interface with the same user credentials.

Bumping this. Am using 5.7.1 codebase 386. The Connection Failure. Wrong Username or password message appears when either generating an LDAP token or testing the connection. Can also see the bad login attempts in the server log.

I'm seeing this with ALL users on the mobile app, not jus LDAP. Have you tried making sure it's not just the LDAP authenticated users?

On an old stable release 6.0.7860 not using LDAP, I can get the app to test the connection and say OK but as soon as I browse for music it says wrong username or password. The login attempt is noted by the server log.
frank2228
 
Posts: 32
Joined: 23 Jul 2014, 00:59
Has thanked: 32 times
Been thanked: 10 times


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest