Server 6.3.9840: Unable to scan media library

Post your Server Bug Report

Server 6.3.9840: Unable to scan media library

Unread postby dLysergic » 13 Aug 2018, 22:37

Code: Select all
=========================================================================================
 VERSION:     MADSONIC 6.3 | BUILD: 9840
 SERVLET:     JETTY
 SERVER:      CPU: AMD RYZEN 5 2400G | ARCH: X64 | MEMORY: 16GB | HDD: 6TB
 OS:          UBUNTU
 SYSTEM:      SERVER
 INSTALLER:   DEB
 JAVA:       ORACLE JRE 1.8.0_151-b12 | HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)
 BROWSER:      FIREFOX 61.0.2
 CLIENT:       DSUB
 DESCRIPTION:  SERVER UNABLE TO SCAN MEDIA LIBRARY
 REPRODUCIBLE: YES
=========================================================================================


When attempting to scan my media library, the log shows this with verbose logging enabled (reverse chronological order) :
[8/13/18 3:19 PM] DEBUG MediaScannerService WATCHDOG:END:
[8/13/18 3:19 PM] ERROR MediaScannerService Failed to scan media library.
[8/13/18 3:19 PM] INFO MediaScannerService WATCHDOG:SCAN: doFullScanLibrary() started


My media library indicates 0mb though I have thousands of songs. I am unable to use the random feature, autodj only finds and plays a single track, genres are completely missing, etc.

Exception in thread "MediaLibraryScanner" java.lang.NullPointerException
at org.madsonic.service.MediaScannerService.doFullScanLibrary(MediaScannerService.java:411)
at org.madsonic.service.MediaScannerService.access$200(MediaScannerService.java:62)
at org.madsonic.service.MediaScannerService$4.run(MediaScannerService.java:209)
dLysergic
 
Posts: 6
Joined: 03 Nov 2014, 21:35
Has thanked: 0 time
Been thanked: 1 time

Re: Server 6.3.9840: Unable to scan media library

Unread postby dLysergic » 13 Aug 2018, 23:59

One thing I tried which was interesting - I added the set of media folders over again (using a different path), set on a different index, and it scanned the entire set of files. That didn't fix my issues with the 'Random' list of albums not loading, or problems in other areas, but the mediascan actually worked. That also confirms that I don't have a permissions or other issue causing my trouble.


[8/13/18 4:46 PM] DEBUG MediaScannerService WATCHDOG:TIMER: UPDATED [myMus]
[8/13/18 4:46 PM] DEBUG MediaScannerService WATCHDOG:TIMER: PLANNED [Music]
[8/13/18 4:46 PM] DEBUG MediaScannerService WATCHDOG:RUN: doUpdateTasks()
[8/13/18 4:46 PM] INFO MediaScannerService Scanned media library with 42000 entries.
... <snipped out> ...
[8/13/18 4:45 PM] INFO MediaScannerService Scanned media library with 2500 entries.
[8/13/18 4:45 PM] INFO MediaScannerService Scanned media library with 2000 entries.
[8/13/18 4:45 PM] INFO MediaScannerService Scanned media library with 1500 entries.
[8/13/18 4:45 PM] INFO MediaScannerService Scanned media library with 1000 entries.
[8/13/18 4:45 PM] INFO MediaScannerService Scanned media library with 500 entries.
[8/13/18 4:45 PM] INFO MusicFolderTasksDao Created task for folder 1
[8/13/18 4:45 PM] INFO MediaScannerService WATCHDOG:SCAN: doFolderScanLibrary() started at Mon Aug 13 16:45:48 MDT 2018
[8/13/18 4:45 PM] INFO MediaScannerService NEXT: Tue Aug 14 03:00:00 MDT 2018
[8/13/18 4:45 PM] INFO MediaScannerService Automatic index scan: every 1 day(s)
[8/13/18 4:45 PM] DEBUG MediaScannerService WATCHDOG:SCHEDULE: 2016-12-31 20:00:00.0 [myMus]
[8/13/18 4:45 PM] DEBUG MediaScannerService WATCHDOG:SCHEDULE: 2018-08-14 13:34:00.0 [Music]
[8/13/18 4:45 PM] INFO SettingsService ## Created Default Access for MediaFolder: myMus
[8/13/18 4:45 PM] INFO SettingsService ## Created MediaFolder: myMus
[8/13/18 4:45 PM] INFO MusicFolderDao Created music folder /mnt/linux-stor/samba/mp3
[8/13/18 4:45 PM] INFO MediaScannerService NEXT: Tue Aug 14 03:00:00 MDT 2018
[8/13/18 4:45 PM] INFO MediaScannerService Automatic index scan: every 1 day(s)
[8/13/18 4:45 PM] DEBUG MediaScannerService WATCHDOG:SCHEDULE: 2018-08-14 13:34:00.0 [Music]
[8/13/18 4:45 PM] DEBUG MediaScannerService WATCHDOG:END:
[8/13/18 4:45 PM] ERROR MediaScannerService Failed to scan media library.
[8/13/18 4:45 PM] INFO MediaScannerService WATCHDOG:SCAN: doFullScanLibrary() started


If I try to initiate a rescan at that point it fails the same as before.
dLysergic
 
Posts: 6
Joined: 03 Nov 2014, 21:35
Has thanked: 0 time
Been thanked: 1 time

Re: Server 6.3.9840: Unable to scan media library

Unread postby dLysergic » 14 Aug 2018, 16:22

The nightly job fails as well:
[8/14/18 3:00 AM] DEBUG MediaScannerService WATCHDOG:END:
[8/14/18 3:00 AM] ERROR MediaScannerService Failed to scan media library.
[8/14/18 3:00 AM] INFO MediaScannerService WATCHDOG:SCAN: doFullScanLibrary() started
dLysergic
 
Posts: 6
Joined: 03 Nov 2014, 21:35
Has thanked: 0 time
Been thanked: 1 time


Return to Bug Reports 6.x

Who is online

Users browsing this forum: No registered users and 1 guest