Album (small) thumbnails don't display correctly

Post your Server Bug Report

Album (small) thumbnails don't display correctly

Unread postby denzoid » 22 Jun 2016, 12:50

I have had this issue using version 5.xx and 6.xx... small thumbnails of cover art look very odd (negative?) I am running Windows 10 Pro. I have tried deleting and (re)adding my music folder and then tried moving to version 6.x server. Still get the same issue. The larger (linked) cover art does display correctly. Most of the images are embedded and/or saved as folder.jpg files within the album directory. Any ideas?
Attachments
thumbcolors.png
denzoid
 
Posts: 3
Joined: 05 Dec 2013, 12:57
Has thanked: 0 time
Been thanked: 0 time

Re: Album (small) thumbnails don't display correctly

Unread postby Jay Freeman » 22 Jun 2016, 16:57

Are you able to open the images in paint/gimp and save them again?

I have 5,000 images and each one displays perfectly (some never used to show for some reason, so I re-saved them)
Jay Freeman
 
Posts: 16
Joined: 25 May 2016, 14:57
Has thanked: 0 time
Been thanked: 7 times

Re: Album (small) thumbnails don't display correctly

Unread postby denzoid » 23 Jun 2016, 18:16

They do display if I open them in Gimp and (re)save them, the thing is my library is 5,141 albums and 82,962 songs. Anyone know of an "easy" way ?
denzoid
 
Posts: 3
Joined: 05 Dec 2013, 12:57
Has thanked: 0 time
Been thanked: 0 time

Re: Album (small) thumbnails don't display correctly

Unread postby Jay Freeman » 24 Jun 2016, 17:51

If you drag and drop one of the incorrect images directly into your browser, does it render correctly?

I'm wondering if the images are badly formatted so not even the browser will be able to show them correctly
Jay Freeman
 
Posts: 16
Joined: 25 May 2016, 14:57
Has thanked: 0 time
Been thanked: 7 times

Re: Album (small) thumbnails don't display correctly

Unread postby Jay Freeman » 24 Jun 2016, 19:04

If you are comfortable with the command line, a tool like imagemagick can recursively fix all your images in one go
Jay Freeman
 
Posts: 16
Joined: 25 May 2016, 14:57
Has thanked: 0 time
Been thanked: 7 times

Re: Album (small) thumbnails don't display correctly

Unread postby 655321 » 31 Aug 2017, 12:33

Sorry for reviving this old Thread.
Has anyone come up with another solution for this problem in the meantime? Resaving the Images is simply not an option for me (and they render perfectly when simply dragged into any browser). Almost all of them were saved with Photoshop CC anyway so I do not see them being the problem (they have been recognised perfectly by any software I threw them at until now). When I click on any of the strangelooking pictures in madsonic, the big version looks perfectly ok. I think the thumbnailcreation of Madsonic is broken somehow.
655321
 
Posts: 1
Joined: 31 Aug 2017, 12:16
Has thanked: 0 time
Been thanked: 0 time


Return to Bug Reports 6.x

Who is online

Users browsing this forum: elvosparsley and 1 guest