Webplayer starts at begin of playlist...

Post your Server Bug Report

Webplayer starts at begin of playlist...

Unread postby KBanause » 12 Jan 2017, 13:43

Code: Select all
=========================================================================================
 VERSION:      MADSONIC 6.2 | BUILD: 9080
 SERVLET:      JETTY
 SERVER:       CPU: Core(TM) i3-4330| ARCH: X64 | MEMORY: 8GB | HDD: 128GB
 OS:           Ubuntu 14.04.5 LTS
 SYSTEM:       SERVER
 INSTALLER:    DEB
 JAVA:         OPEN JDK 1.8
 BROWSER:      CHROME 55
 CLIENT:       Madsonic 6.2 Webclient
 DESCRIPTION:  While playing Webplayer continues with first song when removing any song before the current one
 REPRODUCIBLE: YES
=========================================================================================



Hi,

whenever I remove any songs from the playlist that is listed before the one that is currently played, the next song the webplayer is playing will be the first one in the playlist.

Example:

current playlst:
Code: Select all
1. Song 1
2. Song 2
3. Song 3
4. Song 4 (currently playing)
5. Song 5
6. Song 6
7. Song 7
8. Song 8
9. Song 9


The next one to be played would be Song 5.
But when I remove Song 1, Song 2 or Song 3 (or any combination of those three songs) from the playlist, the next song that the webplayer is playing will be the one that is the first one in the list.

Example:
I remove Song 1 and Song 3. New Playlist:

Code: Select all
1. Song 2
2. Song 4 (currently playing)
3. Song 5
4. Song 6
5. Song 7
6. Song 8
7. Song 9


The next song will be Song 2 and not Song 5.
It doesn't matter if I remove the songs by clicking on the x next to it or if I select multiple songs and remove them using the action menu in the web player ("Selected Songs - Remove")
KBanause
 
Posts: 7
Joined: 10 Jun 2016, 11:26
Has thanked: 1 time
Been thanked: 3 times

Re: Webplayer starts at begin of playlist...

Unread postby Madevil » 23 Jan 2017, 22:45

confirmed, will be fixed with next release. :thumbsup:
User avatar
Madevil
Administrator
Administrator
 
Posts: 926
Joined: 07 Dec 2012, 03:58
Has thanked: 1312 times
Been thanked: 958 times

Re: Webplayer starts at begin of playlist...

Unread postby KBanause » 08 Feb 2017, 12:36

Hi, I just updated to MADSONIC 6.2.9240.3e2ad42.20170203.1043.

It seems to work now, but only when I remove songs from the playlist with the little X on the right side of the playqueue. If I check multiple songs and remove them that way, the player removes also the little animated icon next to the song being played and starts with the new top song in the playqueue after the current song is over.
KBanause
 
Posts: 7
Joined: 10 Jun 2016, 11:26
Has thanked: 1 time
Been thanked: 3 times


Return to Bug Reports 6.x

Who is online

Users browsing this forum: No registered users and 1 guest