getAlbum.view song Array missing

Post your Server Bug Report

getAlbum.view song Array missing

Unread postby michi » 13 Mar 2017, 20:06

Hey there,

i have a problem with the getAlbum.view api.
On some albums the song Array is missing. For what i have tried this affects all albums with a underscore in the name.

Here is a responce where i did have this problem:

Code: Select all
{
   "madsonic-response" : {
      "status" : "ok",
      "version" : "2.5.0",
      "type" : "madsonic",
      "album" : {
         "id" : "433",
         "name" : "So weit so gut_ Die größten Hits aus 25 Jahren",
         "artist" : "Rainhard Fendrich",
         "artistId" : "781",
         "coverArt" : "al-433",
         "songCount" : 16,
         "duration" : 3680,
         "playCount" : 2,
         "created" : "2016-07-08T12:52:06.000Z",
         "year" : 2005
      }
   }
}



Any help on this?
michi
 
Posts: 6
Joined: 02 Jan 2017, 19:50
Has thanked: 2 times
Been thanked: 5 times

Re: getAlbum.view song Array missing

Unread postby michi » 15 Apr 2017, 11:52

@maddevil no help here?

I did some more research, the folder Name contains a underscore, but in the Tag name ist a colon..

Some screenshots:
http://imgur.com/a/zusgI

Thanks
michi
 
Posts: 6
Joined: 02 Jan 2017, 19:50
Has thanked: 2 times
Been thanked: 5 times

Re: getAlbum.view song Array missing

Unread postby mplogas » 17 May 2017, 12:20

Seems also be the case when the AlbumName contains quotation-marks. However, the official MadSonic app doesn't seem affected. Is it using a fallback API?
mplogas
 
Posts: 6
Joined: 17 May 2017, 12:13
Has thanked: 1 time
Been thanked: 3 times

Re: getAlbum.view song Array missing

Unread postby Madevil » 18 May 2017, 07:30

michi wrote:@maddevil no help here?

I did some more research, the folder Name contains a underscore, but in the Tag name ist a colon..

Some screenshots:
http://imgur.com/a/zusgI

Thanks


@michi

This is fixed with the next 6.3 release!
User avatar
Madevil
Administrator
Administrator
 
Posts: 906
Joined: 07 Dec 2012, 03:58
Has thanked: 1320 times
Been thanked: 951 times

Re: getAlbum.view song Array missing

Unread postby Madevil » 18 May 2017, 07:31

mplogas wrote:Seems also be the case when the AlbumName contains quotation-marks. However, the official MadSonic app doesn't seem affected. Is it using a fallback API?


Hi there, can you provide an example for testing ?
User avatar
Madevil
Administrator
Administrator
 
Posts: 906
Joined: 07 Dec 2012, 03:58
Has thanked: 1320 times
Been thanked: 951 times

Re: getAlbum.view song Array missing

Unread postby mplogas » 18 May 2017, 11:04

Sure, want me give you access to my installation or provide logs / screenshots etc?
mplogas
 
Posts: 6
Joined: 17 May 2017, 12:13
Has thanked: 1 time
Been thanked: 3 times

Re: getAlbum.view song Array missing

Unread postby mplogas » 22 May 2017, 15:49

Hi MadEvil,
I haven't received a response yet, however I dug a little deeper.

ISSUE: special chars in the album title seems to remove album titles from the API response
AFFECTED SYSTEM: MADSONIC 6.2.9080, REST API, getAlbum.view
STEPS TO REPRODUCE: Add an album with a couple of track. The albumtag includes a colon or quotation marks. Request to getAlbum.view
EXPECTED BEHAVIOR: getAlbum.view returns an album node containing a couple of song nodes
ACTUAL BEHAVIOR: getAlbum.view returns an album node without any song nodes
POSSIBLE WORKAROUND: if music library is sorted by artist/album use getMusicDirectory endpoint instead to go through the folders

Do you need anything else?
mplogas
 
Posts: 6
Joined: 17 May 2017, 12:13
Has thanked: 1 time
Been thanked: 3 times


Return to Bug Reports 6.x

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron