Page 1 of 1

Madsonic in Docker reports wrong IP to Sonos

Unread postPosted: 16 Aug 2017, 17:20
by Brady
Sonos does not work when running Madsonic in a docker container because it sends the internal Docker IP in place of the actual IP that would be used to connect to the Madsonic web interface.

Take this example... The docker host is at 192.168.1.3 and I access Madsonic by going to 192.168.1.3:4040 because the 4040 port is forwarded to the docker container.

When turning on Sonos in Madsonic, I see the following in the logs...

Code: Select all
[8/16/17 12:14 PM]   INFO   SonosServiceRegistration   Enabling Sonos music service, using Sonos controller IP 192.168.1.53, SID 244, presentationMap 15, stringVersion 8, and Madsonic URL http://172.17.0.1:4040/ws/Sonos



172.17.0.1 is the IP that Docker assigns to Madsonic. Sonos should actually target 192.168.1.3.

I know that the Docker really doesn't know the host IP... so what I would like to see is a way to override this IP in the madsonic.properties file.

This was tested on 6.3.9540.3e2ad42.20170703.120 (the latest on the docker betas)

Re: Madsonic in Docker reports wrong IP to Sonos

Unread postPosted: 17 Aug 2017, 02:34
by Madevil
We will examine and test this option in an upcoming release.

best regards,
The Madsonic Team